RFC 10023 - A DNS convention for signalling domains for sale
Hello, I would like to make this group aware of RFC 10023, recently published by the IETF: https://www.rfc-editor.org/rfc/rfc10023 The RFC defines a simple DNS convention for signalling that a registered domain name is currently being offered for sale. It uses a TXT record at a reserved DNS node name: _for-sale.example.com For example: _for-sale.example.com. 300 IN TXT "v=FORSALE1;furi=https://example.com/buy" The idea is to make the sale status of a domain machine-readable and directly discoverable through DNS. The convention requires no changes to DNS protocols or infrastructure. It is entirely voluntary and can be used by domain owners, registrars, registries and service providers. It may also be useful for DNS monitoring, domain intelligence and automated discovery tools. There is already quite some operational experience with this approach. More information, including implementation details and examples, is available at: https://rfc10023.nl/ I thought this might be of interest to people working with DNS and domain infrastructure. Best regards, -- Marco Author of RFC 10023.
On 31 October 2026 08:20:03 CET, "Marco Davids (Private) via NANOG" <nanog@lists.nanog.org> wrote:
Hello,
I would like to make this group aware of RFC 10023, recently published by the IETF:
https://www.rfc-editor.org/rfc/rfc10023
The RFC defines a simple DNS convention for signalling that a registered domain name is currently being offered for sale. It uses a TXT record at a reserved DNS node name:
_for-sale.example.com
For example:
_for-sale.example.com. 300 IN TXT "v=FORSALE1;furi=https://example.com/buy"
The idea is to make the sale status of a domain machine-readable and directly discoverable through DNS.
The convention requires no changes to DNS protocols or infrastructure. It is entirely voluntary and can be used by domain owners, registrars, registries and service providers. It may also be useful for DNS monitoring, domain intelligence and automated discovery tools.
There is already quite some operational experience with this approach.
More information, including implementation details and examples, is available at: https://rfc10023.nl/
I thought this might be of interest to people working with DNS and domain infrastructure.
Best regards,
-- Marco Author of RFC 10023.
_______________________________________________ NANOG mailing list https://lists.nanog.org/archives/list/nanog@lists.nanog.org/message/OLYY3J5Z...
Hopefully this helps the registry to discover that the domain is being boarded, contrary to ToS, and terminate it without refund so we can have less hoarded domains everywhere.
For the uninitiated who may misinterpret this : - RFC10023 is an Informational RFC. - Informational RFCs are NOT internet standards. They are defined in RFC2606 : https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2.2 An "Informational" specification is published for the general
information of the Internet community, and does not represent an Internet community consensus or recommendation.
This idea is functionally no different than any other TXT record that you could add into the DNS. Unless you are frequently buying and selling domains, you almost certainly don't care about this at all. On Sat, Oct 31, 2026 at 3:20 AM Marco Davids (Private) via NANOG < nanog@lists.nanog.org> wrote:
Hello,
I would like to make this group aware of RFC 10023, recently published by the IETF:
https://www.rfc-editor.org/rfc/rfc10023
The RFC defines a simple DNS convention for signalling that a registered domain name is currently being offered for sale. It uses a TXT record at a reserved DNS node name:
_for-sale.example.com
For example:
_for-sale.example.com. 300 IN TXT "v=FORSALE1;furi=https://example.com/buy "
The idea is to make the sale status of a domain machine-readable and directly discoverable through DNS.
The convention requires no changes to DNS protocols or infrastructure. It is entirely voluntary and can be used by domain owners, registrars, registries and service providers. It may also be useful for DNS monitoring, domain intelligence and automated discovery tools.
There is already quite some operational experience with this approach.
More information, including implementation details and examples, is available at: https://rfc10023.nl/
I thought this might be of interest to people working with DNS and domain infrastructure.
Best regards,
-- Marco Author of RFC 10023.
_______________________________________________ NANOG mailing list
https://lists.nanog.org/archives/list/nanog@lists.nanog.org/message/OLYY3J5Z...
On Sat, Oct 31, 2026, 11:53 Tom Beecher via NANOG <nanog@lists.nanog.org> wrote:
For the uninitiated who may misinterpret this :
- RFC10023 is an Informational RFC. - Informational RFCs are NOT internet standards. They are defined in RFC2606 : https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2.2
That's because, loosely, the standards track defines "MUST"s. When definining "protocols" (in the broad sense of the word), informationals define "MAY"s. Sure, RFC 2549 (RFC 1149, "the pigeon plus QoS one") is "Informational." But you know what else is? 2818 (HTTPS) 6446 (TLS Extensions) 3849/9637 (IPv6 documentation/example prefixes) 9775 (the IRTF CoC) and many, many, MANY others. Currently, 3013 of RFCs are in the Informational status. The only status with more than that is Proposed Standard with 4434 RFCs (there are only 133 Internet Standards and 337 BCPs). So I wouldn't get too hung up on it being "Informational". It can hold a lot more weight than you give it credit for here.
Informational RFCs have their place. I am not arguing that they do not. This particular subject is perfectly acceptable as an info RFC. However, a long-running trend exists where people publish an info RFC, and then proceed to promote it in a way that implies it's an accepted standard to garner adoption. The OP didn't here, but has done that elsewhere. I know that you know the distinctions between the RFC types, but many don't, and that's the only reason I replied as such. On Sat, Oct 31, 2026 at 2:20 PM brent saner via NANOG <nanog@lists.nanog.org> wrote:
On Sat, Oct 31, 2026, 11:53 Tom Beecher via NANOG <nanog@lists.nanog.org> wrote:
For the uninitiated who may misinterpret this :
- RFC10023 is an Informational RFC. - Informational RFCs are NOT internet standards. They are defined in RFC2606 : https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2.2
That's because, loosely, the standards track defines "MUST"s. When definining "protocols" (in the broad sense of the word), informationals define "MAY"s.
Sure, RFC 2549 (RFC 1149, "the pigeon plus QoS one") is "Informational."
But you know what else is?
2818 (HTTPS) 6446 (TLS Extensions) 3849/9637 (IPv6 documentation/example prefixes) 9775 (the IRTF CoC)
and many, many, MANY others.
Currently, 3013 of RFCs are in the Informational status. The only status with more than that is Proposed Standard with 4434 RFCs (there are only 133 Internet Standards and 337 BCPs).
So I wouldn't get too hung up on it being "Informational". It can hold a lot more weight than you give it credit for here. _______________________________________________ NANOG mailing list
https://lists.nanog.org/archives/list/nanog@lists.nanog.org/message/ZUHT7EGV...
On 31 October 2026 19:52:07 CET, Tom Beecher via NANOG <nanog@lists.nanog.org> wrote:
Informational RFCs have their place. I am not arguing that they do not. This particular subject is perfectly acceptable as an info RFC.
However, a long-running trend exists where people publish an info RFC, and then proceed to promote it in a way that implies it's an accepted standard to garner adoption. The OP didn't here, but has done that elsewhere.
I know that you know the distinctions between the RFC types, but many don't, and that's the only reason I replied as such.
On Sat, Oct 31, 2026 at 2:20 PM brent saner via NANOG <nanog@lists.nanog.org> wrote:
On Sat, Oct 31, 2026, 11:53 Tom Beecher via NANOG <nanog@lists.nanog.org> wrote:
For the uninitiated who may misinterpret this :
- RFC10023 is an Informational RFC. - Informational RFCs are NOT internet standards. They are defined in RFC2606 : https://www.rfc-editor.org/rfc/rfc2026.html#section-4.2.2
That's because, loosely, the standards track defines "MUST"s. When definining "protocols" (in the broad sense of the word), informationals define "MAY"s.
Sure, RFC 2549 (RFC 1149, "the pigeon plus QoS one") is "Informational."
But you know what else is?
2818 (HTTPS) 6446 (TLS Extensions) 3849/9637 (IPv6 documentation/example prefixes) 9775 (the IRTF CoC)
and many, many, MANY others.
Currently, 3013 of RFCs are in the Informational status. The only status with more than that is Proposed Standard with 4434 RFCs (there are only 133 Internet Standards and 337 BCPs).
So I wouldn't get too hung up on it being "Informational". It can hold a lot more weight than you give it credit for here. _______________________________________________ NANOG mailing list
https://lists.nanog.org/archives/list/nanog@lists.nanog.org/message/ZUHT7EGV...
_______________________________________________ NANOG mailing list https://lists.nanog.org/archives/list/nanog@lists.nanog.org/message/47TZ2MVD... AIUI, many informational RFCs are describing things that are already done in practice, so there is no opportunity for the standards track process to amend them and there is no point putting them through the standards track process.
Kevin (Does anyone know how to get K9 Mail to stop converting my top replies to bottom replies? Answer off-list)
On Sat, Oct 31, 2026 at 2:52 PM Tom Beecher <beecher@beecher.cc> wrote:
Informational RFCs have their place. I am not arguing that they do not. This particular subject is perfectly acceptable as an info RFC.
Fully agreed!
However, a long-running trend exists where people publish an info RFC, and then proceed to promote it in a way that implies it's an accepted standard to garner adoption. The OP didn't here, but has done that elsewhere.
This is also true. I'd consider many Informational to be "Virtually Standard", though, and even some BCPs require Informationals as requisite for implementation. So it's certainly not as clear-cut over the years as the IETF likely originally intended it to be. (Though you are right in that it doesn't help that there's plenty of ...*opportunistic*, to be generous, framing of some of them.)
I know that you know the distinctions between the RFC types, but many don't, and that's the only reason I replied as such.
Of course, I just thought it important to mention the grain of salt of "your network's probably going to break and you'll get many angry phonecalls if you ignore Informational". ;)
Gosh, it would be terrible if folks were to use this DNS record as a negative reputation indicator, suggesting that it might be best to disallow mail or traffic from a domain given that it is likely owned by a domain speculator or hoarder. -- Al Iverson // 312-725-0130 // Chicago http://www.spamresource.com // Deliverability http://www.aliverson.com // All about me https://xnnd.com/calendar // Book my calendar
-----Original Message----- From: Al Iverson via NANOG <nanog@lists.nanog.org>
Gosh, it would be terrible if folks were to use this DNS record as a negative reputation indicator, suggesting that it might be best to disallow mail or > traffic from a domain given that it is likely owned by a domain speculator or hoarder.
My first thought of what this would actually end up being used for is certain ISP's to further "maximize shareholder value" by intercepting web requests for these domains like some do now for NXDOMAIN. Serve up some targeted ads, attempt to insert yourself into the sales process, whatever. Although to fully monetize you need to get paid from both sides. So also sell the customer info as a "warm lead" back to the domain seller. Adam "The Monetizer" Maloney
According to Adam Maloney via NANOG <nanog@lists.nanog.org>:
-----Original Message----- From: Al Iverson via NANOG <nanog@lists.nanog.org>
Gosh, it would be terrible if folks were to use this DNS record as a negative reputation indicator, suggesting that it might be best to disallow mail or > traffic from a domain given that it is likely owned by a domain speculator or hoarder.
Having opportunistically bought and sold a few domains over the years, that would be fine. I can't ever think of a domain offered for sale that had mail traffic anyone cared about. The closest is when someone out of the blue offered me significant money for one of my .com domains and I made a private arrangement to keep an MX pointing to me for a while as I moved the few mail users to the corresponding .org.
My first thought of what this would actually end up being used for is certain ISP's to further "maximize shareholder value" by intercepting web requests for these domains like some do now for NXDOMAIN. Serve up some targeted ads, attempt to insert yourself into the sales process, whatever.
Um, you might want to familiarize yourself with domain parking services. You don't need any funny business to put a website full of junk ads on a domain you're trying to sell.
Although to fully monetize you need to get paid from both sides. So also sell the customer info as a "warm lead" back to the domain seller.
I know of one person who's scanning for _for-sale tags and making a directory. Maybe he wants to be a broker. Why should anyone care? R's, John -- Regards, John Levine, johnl@taugh.com, Primary Perpetrator of "The Internet for Dummies", Please consider the environment before reading this e-mail. https://jl.ly
-----Original Message-----
From: John Levine via NANOG <nanog@lists.nanog.org>
My first thought of what this would actually end up being used for is certain ISP's to further "maximize shareholder value" by intercepting web requests for these domains like some do now for NXDOMAIN. Serve up some targeted ads, attempt to insert yourself into the sales process, whatever.
Um, you might want to familiarize yourself with domain parking services. You don't need any funny business to put a website full of junk ads on a >domain you're trying to sell.
I am plenty familiar. I think you've misunderstood the scenario. I'm talking about an end-user trying to browse to your for-sale domain. The user's ISP (handling the DNS query) sees your domain's for-sale TXT record and redirects the user to their (the user's ISP) own site. Like some do now for NXDOMAIN. You, the domain seller, would never get their web traffic and so would lose out on that junk ad money. The user's ISP would get it (if they run ads, or they could monetize it in a dozen other ways.) Apologies if this wasn't clear. Adam
On Mon, 2 Nov 2026, Adam Maloney wrote:
I am plenty familiar. I think you've misunderstood the scenario. I'm talking about an end-user trying to browse to your for-sale domain. The user's ISP (handling the DNS query) sees your domain's for-sale TXT record and redirects the user to their (the user's ISP) own site. Like some do now for NXDOMAIN.
I suppose that's hypothetically possible but it's hard to imagine it'd be worth the effort. There are a lot of domains for sale (even though few have the tag) and most are basically worthless. It is also my impression that turning NXDOMAIN into web ads has largely gone away. A lot of the ISPs I see don't even bother to provide a DNS cache and point the customers at 1.1.1.1 or 8.8.8.8. R's, John
On 2026-11-01 09:04, Al Iverson via NANOG wrote:
Gosh, it would be terrible if folks were to use this DNS record as a negative reputation indicator, suggesting that it might be best to disallow mail or traffic from a domain given that it is likely owned by a domain speculator or hoarder. If you hold the position that CyberSquatters suck and return NXDOMAIN on this resource for all your customers as a service. Doesn't this sort of reverse it's purposed intent?
According to Chris via NANOG <nanog@lists.nanog.org>:
On 2026-11-01 09:04, Al Iverson via NANOG wrote:
Gosh, it would be terrible if folks were to use this DNS record as a negative reputation indicator, suggesting that it might be best to disallow mail or traffic from a domain given that it is likely owned by a domain speculator or hoarder. If you hold the position that CyberSquatters suck and return NXDOMAIN on this resource for all your customers as a service. Doesn't this sort of reverse it's purposed intent?
Why am I getting the feeling that I've fallen through a wormhole into about 1999? -- Regards, John Levine, johnl@taugh.com, Primary Perpetrator of "The Internet for Dummies", Please consider the environment before reading this e-mail. https://jl.ly
participants (9)
-
Adam Maloney -
Al Iverson -
brent saner -
Chris -
John Levine -
John R. Levine -
Kevin Tillery -
Marco Davids (Private) -
Tom Beecher